NanoStudio V1.42 now available

7 replies [Last post]
Blip Interactive
Offline
Joined: 04/05/2010

*** SORRY, PLEASE DON'T UPDATE TO THIS VERSION - SOMETHING BAD HAS HAPPENED TO THE REVERB IN 1.42 ***

NanoStudio V1.42 should be available in the app store within an hour or two, which tidies up a couple of things:

* Updated to Audiobus SDK 1.0.2 for improved compatibility with iOS7
* Fix for app closing when in background (and/or corrupted MIDI port settings)

I'll admit the first one (Audiobus) sounds pretty vague, mainly because I'm not sure what 'compatibility' is 'improved'! Still, the Audiobus guys recommend that all developers update to this version sooner rather than later.

The second one should hopefully fix an issue reported by some users.

Cheers

Matt

andyxr
Offline
Joined: 07/01/2012

Eeek. Upgraded this morning and now some of my patches sound like a wirebrush being scraped over rusty piano strings! Ouch.

Blip Interactive
Offline
Joined: 04/05/2010

I've already had one other report of this via email. I've been unable to reproduce this myself, but with a second report the signs don't look good.

Have you tried closing background apps and/or rebooting your device? If you have and it hasn't helped, any chance you could give me more info, ie:

- The device your using (iPhone/iPad, version)
- The version of iOS you are running
- Is it only certain patches? If so, is there anything about these patches in particular? (ie. maybe they use samples, or a particular effect)

Blip Interactive
Offline
Joined: 04/05/2010

Oh dear it looks to me like the reverb has become screwed. I'll give you more info once I've had a chance to work out what's happened.

andyxr
Offline
Joined: 07/01/2012

iOS7
iPad 2
All apps were closed; device restarted; only NS running
Yeah, reverb seems to be the culprit.

Andy

Blip Interactive
Offline
Joined: 04/05/2010

OK thanks for the info - I'm on it.

demochx
Offline
Joined: 09/20/2013

hi Blip!

Sorry that this ist he first time i post here. Your product is awsome. i loved it on my iphone but with an ipad its just pure joy.
First i would like to state that an VST-Version (of eden) would be great. But now the reason for posting. i updated to ios 7 on my ipad3 and everything was fine (fine means, nanostudio and touchOSC were still workin ... yeaii). However, this morning i started NS again, and there was something really wrong. as you said, the REVERB is screwed up (badly).

i tried to revert to ios6, no chance. and questionable, if the reverb would be fine again.

i look forward for an update
please keep up your excellent work.

greetz from germany, mark

demochx
Offline
Joined: 09/20/2013

maybe its just an ipad<4 iphone <5 issue?

edit: ok, now i looked through the threads, it seems obvious, that you screwed up the 1.42 version concerning the reverb.
again, this is the most advanced music production center app one could ask for. thumbs up.
cheers, mark