Nanostudio 1.40 Leopard compatibility?

3 replies [Last post]
Cal
Offline
Joined: 01/30/2011

Not sure if Nanostudio 1.40 is meant to run in OSX 10.5.8 but i tried it on a dual core iMac and got the app quit unexpectedly message. This is the Apple error report:
--------------------------------------------------------------------------------
Process: NanoStudio [18471]
Path: /Applications/NanoStudio.app/Contents/MacOS/NanoStudio
Identifier: co.uk.blipinteractive.NanoStudio
Version: ??? (???)
Code Type: X86 (Native)
Parent Process: launchd [105]

Interval Since Last Report: 23007593 sec
Crashes Since Last Report: 139548
Per-App Interval Since Last Report: 0 sec
Per-App Crashes Since Last Report: 9

Date/Time: 2013-05-21 13:05:14.363 +0100
OS Version: Mac OS X 10.5.8 (9L31a)
Report Version: 6
Anonymous UUID: 98CD48B5-4D4E-41FB-BEBA-45189FB471C5

Exception Type: EXC_BREAKPOINT (SIGTRAP)
Exception Codes: 0x0000000000000002, 0x0000000000000000
Crashed Thread: 0

Dyld Error Message:
unknown required load command 0x80000022
--------------------------------------------------------------------------------
On the Tablet and Phone versions I received a different error window:
https://www.dropbox.com/s/qp5l0a058afzg8v/Picture1.png
It's not a problem for me (as I normally use Snow Leopard) but thought it was worth reporting.

Blip Interactive
Offline
Joined: 04/05/2010

When it was on the distributed on the app store it had to support later OS versions only, so I removed some old stuff. It could easily be due to this. I haven't got time right now to add the old support stuff back in I'm afraid.

Cal
Offline
Joined: 01/30/2011

Not a problem for me but you may want to change the "Minimum System Requirements" text in the "ReadMe" file. Just a thought.

noelleis
Offline
Joined: 10/23/2012

Yes. NanoStudio is only supported on 10.6+
I just tried this on a friend's laptop running 10.5.8.