Nanosync NOT syncing

15 replies [Last post]
some1cool
Offline
Joined: 07/08/2011

O.k. so the Nanosync part of this operation just ain’t working for me .. at all
& I grasp the concept of what is supposed to happen, but its not.
My device (the 4th Gen Ipod Touch) is picking up & displaying an ip address
All is cool on that end, no problem with the “device”
But like most who I’ve seen on the forum who do not have any success with this
(like Briscoe27) my laptop is failing to engage in the sync process.

I’ve tried manually inputting the ip address from my Ipod's Nanostation window
I’ve reinstalled the Nanosync numerous times on my computer
& I’ve went to a whole slew of different Wi-Fi locations with “excellent” signals
To get different ip addresses
But when I click “connect” on my computer
I have had no luck getting anything to happen. Nada

If this is essentially a drag & drop program
why does this require syncing in a way that involves a network.??
Why is this not set up in a way that enables users to download or sync files solely from computer to our devices
In the same or similar manner that music, video & other Apps are added to our devices.

In any event .. I would love to get going with this,
I’ve been creating beats on the train, on the toilet .. everywhere
& I want to add other sampled sounds & go to other levels
can someone offer a life preserver
Or floatation device to help me get out of these waters.. S.O.S. Help.!!!

Jim Hanks
Offline
Joined: 06/14/2011

Make sure you press the Enable button in NanoStudio then press the Connect button in NanoSync then press the 'Refresh List' button in NanoSync if necessary - you should see your device in NanoSync and can click OK. Then you should see the folders/files to be able to drag-n-drop between NanoSync and folders on the computer.

some1cool
Offline
Joined: 07/08/2011

Thank u sir.. i know the sequence already
its pretty clearly stated in the "Help" Tab, & i followed every detail of the instructions
& no results

the Nanosync on my laptop doesnt register anything..
the little white box stays empty..
then i tried inputting the IP address manually & no results

Blip Interactive
Offline
Joined: 04/05/2010

It's always difficult to diagnose these problems since they're usually to do with a specific network/router setup. I know it makes total sense to sync via USB and/or iTunes but Apple don't give developers access to the necessary functions which is why so many 'power' applications have their own solutions (which are normally WiFi based).

So, just to confirm where you've got to:

- On the phone the MANAGE/NanoSync page shows that it's ready with a yellow light and an IP address
- In NanoSync you see your device listed but it fails to connect using the 'Found Device' method
- If you try the manual method by entering the IP address, it still fails to connect
- NanoSync doesn't give you any error or status message (eg. timeout?)

I think the first thing to try would be briefly disabling your Windows firewall to see if it's causing the problem. I don't know what OS you're using so it's probably best to Google for this and you'll find some good instructions. If it works, then you probably just need to add NanoSync to the firewall as an exception.

The next thing would be to try setting up an ad-hoc network (this is like a separate network where your computer acts as the router). It should only take a few minutes to try out - example instructions for XP are here http://www.microsoft.com/windowsxp/using/networking/setup/adhoc.mspx but you can Google for others. Make sure you tell your phone to connect to this WiFi network rather than your router's one.

The final solution would be to bypass NanoSync altogether and try using a program like iPhone Explorer http://www.macroplant.com/iphoneexplorer/ NanoStudio's files are under Apps/NanoStudio/Documents/User, and you'll need to ensure that wav files have been converted to 16 bit before you copy them over since NanoSync normally performs this function for you.

pablo64
Offline
Joined: 06/23/2011

Hi some1cool,

Be careful you don't press 'sample' when you're on the toilet......!

I've managed to avoid the whole nanosync/wifi issue by using a free program called 'iphone explorer' and connecting my iPod via usb to my PC. (There's a Mac version too.) This works just like Windows explorer so you can navigate to your samples or projects folder and drag anything you want into it.
The sequence is: Apps --> Nanostudio -->Documents -->User -->Projects/Samples/TRG Banks

Occasionally I get a 'File or Folder Not Found' message but closing and reopening the program normally solves that. Generally it works like a dream!

Here's the link: http://www.macroplant.com/iphoneexplorer/

Hope this helps.

pablo64
Offline
Joined: 06/23/2011

Sorry Blip,
Looks like we were writing more or less the same thing, to the same person at the same time!
SPOOKY!

Whilst you're there though I'd like to ask you about the waveforms in Eden. How do they differ from samples and is it possible to customise them? It would be great to have a sort of LA synthesis which it kind of already is but apparently restricted to the supplied waveforms.

I'm obsessed with this app, it's awesome!

Blip Interactive
Offline
Joined: 04/05/2010

The main differences between waveforms and samples are:

- Waveforms are anti-aliased (effectively, they sound a lot better over the whole range)
- Waveforms are dual with inter-modulation options (really more of a UI space limitation for samples)

It's not really possible to customise the waveforms because they're built in a particular way to support anti-aliasing.

pablo64
Offline
Joined: 06/23/2011

Thanks for the reply!
I kind of understand what you mean, I think!
Do you think you would/could ever implement a way of combining samples and oscillators on a single Eden synth (or maybe a new synth)? I realise that over midi I could layer two or more Edens and have one using a sample and the other/s using the oscillator waveforms to create composite sounds and then resample the output but it would be so great to be able combine the two on one device and then save the patch.
Having said that I actually quite like limitations and workarounds as I think they make me more creative so I don't really mind if it never happens!

some1cool
Offline
Joined: 07/08/2011

Blip & Pablo.. Thanks for all the Info in your replies. i'm gonna get right on it now & see what i can make happen.

BTW - (regarding the Blip Reply)
"- In NanoSync you see your device listed but it fails to connect using the 'Found Device' method"

i never got as far as being able to see anything in the NanoSync Window
thats why i tried to enter the IP address manually.. coz that white box in NanoSync never registered anything

Also, i'm using the Windows XP operating system (SP 3)
i never wanted to venture into the chaos of Vista or 7 - & i've been fine.

i do use Vipre .. but i manually turn off the Firewall & everything else that could interfere
but i still do not get any results
(with other situations that the Firewall would block, turning it off usually worked for me)

Thanks again for all the feedback.. i hope one of the suggestions work.. Peace

pablo64
Offline
Joined: 06/23/2011

some1cool,

Glad to be able to help.
Keep at it with Nanosync I'm sure you'll get there in the end and there's an advantage over iPhone explorer that I didn't know about in the automatic conversion of wav files to 16 bit, very useful.
The only reason I went straight to iPhone explorer was because when I first got my broadband I never bothered setting up a wireless link as I thought it might be less secure. I'm sure it's not if you set up passwords but I've just never got round to sorting it and drag and drop works well for me so I've stuck with it!

some1cool
Offline
Joined: 07/08/2011

i downloaded the Iphone Explorer & tried to follow the path that you both suggested
but when i double-clicked on the folder that say "Blipinteractive NanoStudio"
an error message popped up that said: "File or Directory not found"

Has any one encountered this before.. is there a way to resolve the error message & move on.??

some1cool
Offline
Joined: 07/08/2011

This is the email that i just sent to Microplant's Support (the makers of Iphone Explorer)

Hello Macroplant.com

i downloaded your software iPhone Explorer yestersday
(as recommended on a site for NanoStudio - a Music making App)

i'm trying to be able to move files from my computer to the Nanostudio App
that is on my Ipod Touch (4th Gen).

The installation of iPhone Explorer went fast & smoothly
& when i opened the the program it shows folders for the contents on my device.
Then i click on the "Apps" folder, & the contents of my Ipod touch
pop up into a window on the right side.

But when i click on the NanoStudio Folder (or any folder)
an Error Message pops up, that reads "File or Directory not found" (see attachment)

is there a way that i can remedy this problem & get the iPhone Explorer to work.??

Thank You

Reo

pablo64
Offline
Joined: 06/23/2011

some1cool,

As I said in my first reply, this message occasionally pops up on the first try but closing the program and relaunching it usually solves the problem.
If you keep getting the same message, launch iTunes and keep it open before you launch iPhone explorer

some1cool
Offline
Joined: 07/08/2011

Got it.. its working.

i had to reinstall.. & i made sure to start Itunes first
that seem to make it work..

Thanks for the feedback..

& that little itunes "Launch 1st" Nugget (Pablo)

Peace

pablo64
Offline
Joined: 06/23/2011

Great news some1cool! Glad you got it working.

Another hopefully useful tip about iPhone explorer is that if you are browsing the file tree of Nanostudio, for example and you want to move to browsing another app, you can't! (At least I can't!) The same message pops up. You have to close iPhone explorer and then re-open it each time you want to change to a different apps directory. This is slightly annoying as it means that if you want to transfer samples between apps, the only way to do it is to drag the samples to the desktop, close iPhone explorer, re-open it, open the other apps directory and drag the samples from the desktop to the other app. A bit of a pain really! Hopefully they'll be able to fix this in future updates.

Dsounder
Offline
Joined: 07/10/2012

hi,
re the converting to 16 bit before coping using iexplorer, how do we do this?
is this done when you make a nsp file?

thanks