Unable to record into Nanostudio with AudioBus

3 replies [Last post]
jbw
Offline
Joined: 11/02/2013

I cannot record into Nanostudio through Audiobus. Looking at the update history it seems like Nanostudio is due for an update, perhaps that will fix it. Or maybe I'm not opening the apps in a proper sequence (that seems to work in some instances).

Device used: iPhone 6+ running iOS 9.2

Any help is appreciated.

jbw
Offline
Joined: 11/02/2013

Just browsed through the forum, kinda looks like Nanostudio 2 is on the way, in a vague sort of way.

To be honest, this problem of AudioBus not recording into Nanostudio can be ignored as far as I'm concerned, as I'd much rather see time spent on Nanostudio 2. :)

Stiksi
Offline
Joined: 11/21/2010

Yes, that's the plan, apparently. It is very unlikely that NS1 is going to get any more updates because Apple would require it to be converted to 64bit which would take a lot of work.

However, you can bypass the Audiobus issue by recording to Loopy, Audioshare or some other app that supports audiocopy and then just copy the samples over. Personally, I always found Nanostudio's audiobus implementation very clunky and never used it because copying was faster for me. I'm sure you already knew this, but just making sure. :)

Slam-Cut
Offline
Joined: 09/07/2011

Yeah, the problem is iOS 9. It broke AB and when AB was fixed, NS got left behind since the dev is closer to finishing NS2 than would make sende to re-write NS. The work-arounds are OK for now, but I am looking forward to NS2 releasing this year.