USB controller

8 replies [Last post]
snekkis
Offline
Joined: 02/12/2015

Bought the app for my iPhone, but I would really like this to work on my PC too.

I have an Akai MPK25 and Oxygen 88, which both show up in MIDI inputs. I can choose either OMNI or ENABLE, I pick an isntrument, but it won't play from the controller any instrument.

Tested the Akai on my Macbook and worked fine.

Running Win 8.1, if that have anything to do with it

syrupcore
Offline
Joined: 09/26/2010

Does it work with any other software?

snekkis
Offline
Joined: 02/12/2015

The controllers work fine in Reason 8.1. I have installed Balance soundcard and driver, but the Nanostudio is playing through optical, not the Balance.

I can play the demo songs and play virtual keyboard. It's just the midi that would not play.

Stiksi
Offline
Joined: 11/21/2010

If you select OMNI, the keyboard will control the device that is in view. But Enable should be always on.

Check the midi channel on your keyboard. If OMNI is set to off, the keyboard will control the device that corresponds with the midi channel:

Midi CH 1 = Instrument 1 (it skips the mixer, which is also considered an instrument)
Midi CH 2 = Instrument 2

Midi CH 15 = Instrument 15

Also, the Midi channel selection on the MIDI settings page will indicate if there is incoming midi. Play notes and see if any of the lights flash.

What I don't know is why there are 16 channels to enable in the midi settings page. That's one more than there are controllable instruments. Syrupcore?

snekkis
Offline
Joined: 02/12/2015

No lights flashing on the MIDI channel buttons, but they do not flash on the Mac either. The Mac works

I'm not that familiar with the controllers and on board programming and stuff. I am just used to plug and play. I looked inside the manual for my Oxygen 88, but it blames the software if it does not receive MIDI.

I plugged my sons very simple Samson Carbon61 keyboard controller, just to exclude any complicated preset of programming from the controller. NanoStudio detects the controller right away assigned with the right name and everything. Same thing, no sound. I don't get it. It looks to me as something simple to fix, but what? Its not much to tweak for troubleshooting on either

Stiksi
Offline
Joined: 11/21/2010

If you have pressed "Enable" it should work. Sounds like something's wrong. I guess we'll have to wait for Blip to respond unless someone has had the same problem.

Blip Interactive
Offline
Joined: 04/05/2010

Strange, I haven't had any specific reports of problems. It should just be a case of going to the MANAGE/MIDI page and setting the MIDI Input Device to the one you want using the -/+ buttons. If it can enable the chosen device then the green Active indication should come on, and then you should see the red MIDI In indicator light whenever it gets controller or note events.

If the green indicator's on but there are no MIDI In signals then I'd expect it to be more of a hardware setting, but if the controller works fine in other apps that doesn't sound likely either. It might be worth closing everything else, just in case it's taking control of that MIDI port.

Beyond that, I have to say I'm currently out of ideas.

snekkis
Offline
Joined: 02/12/2015

I had installed Nanostudio on both my sons computers. Both running Win 8.1. What I did see when running the installer, what looked like third party driver. I don't remember seeing that driver installed on my computer, running installer.

But anyway, I tried the Samson controller on both. It was not working on one of them. I could also see midi channel one receiving note as it was flashing.

I just wonder about if i'm right about that third party driver?

Blip Interactive
Offline
Joined: 04/05/2010

There shouldn't be any third party driver installed by the NanoStudio installer. It does run something called the 'DirectX XAudio2 Redistributable', but this is a common Microsoft component used to ensure that you have Direct X audio installed on your computer - nothing to do with MIDI part of things.

Unfortunately I'm out of ideas on this one, sorry!